[Wannier] Problems with the updated pw2wanier90 interface

Giovanni Pizzi giovanni.pizzi at epfl.ch
Thu Mar 27 12:33:43 CET 2014


Dear Temok,

There are different possible reasons for such an error, depending on which version of Quantum Espresso you are using.
In particular, after the release of Wannier90 2.0, the QE code has changed some internal details, and therefore the pw2wannier90.f90 file that we provide is not working anymore with the most recent SVN version of QE.

However, it should work with QE 5.0.2 patched with the 5.0.3 patch that you can find on the QE website.
Could you try to use the 5.0.2 + 5.0.3 patch of Quantum Espresso (if you are not using it already) together with the pw2wannier90.f90 file provided with Wannier90 2.0, and report us if the problem is solved?

Thanks,
Giovanni

--
Giovanni Pizzi
Post-doctoral Research Scientist
EPFL STI IMX THEOS
MXC 340 (Bâtiment MXC)
Station 12
CH-1015 Lausanne (Switzerland)
Phone: +41 21 69 31124




On 26 Mar 2014, at 03:04, Cuauhtemoc Salazar wrote:

Dear Forum Members,

I am having problems to work out the examples provided in the wannier90-2.0.0 distribution that require the updated pw2wannier90.f90 code, which is provided by wannier90 at
 wannier90-2.0.0/pwscf/v5.0

Firstly, I successfully reproduced examples 01 to 05 using the original pw2wanier90.f90 code provided within  QEspresso_5.0.2  (such example does *not* require the updated version of pw2wannier90, but I started with this simpler example before moving to the actual example of my interest, example18 --Berry curvature).

Then, following
    wannier90-2.0.0/pwscf/README
I did the replacement
cp   wannier90-2.0.0/pwscf/v5.0/pw2wannier90.f90   espresso-5.0.2/PP/src/.

and re-built the PP part of QE:
cd  ~/espresso-5.0.2/PP
make pp

Then I tried to reproduce (again) the wannier90-2.0.0/examples/example05
(running pw2wannier90 with the same number of processors as pw.x,
 as indicated in the w90 tutorial guide, page 10)
but got a number of errors, appended at the end of this message.

I wonder if someone could have an advice to solve this,
With regards,

Temok


[panther2:46075] *** Process received signal ***
[panther2:46075] Signal: Segmentation fault (11)
[panther2:46075] Signal code: Address not mapped (1)
[panther2:46075] Failing at address: (nil)
[panther2:46075] [ 0] /lib64/libpthread.so.0() [0x30de60f710]
[panther2:46075] [ 1] /lib64/libc.so.6(memcpy+0x35) [0x31a0289985]
[panther2:46075] [ 2] /home/temok/opt/openmpi-1.6.5/build-gcc/lib/libmpi.so.1(opal_convertor_pack+0x196) [0x7fbca07d61a6]
[panther2:46075] [ 3] /home/temok/opt/openmpi-1.6.5/build-gcc/./lib/openmpi/mca_btl_sm.so(mca_btl_sm_sendi+0x23d) [0x7fbc9c7d065d]
[panther2:46075] [ 4] /home/temok/opt/openmpi-1.6.5/build-gcc/./lib/openmpi/mca_pml_ob1.so(mca_pml_ob1_send_request_start_copy+0xb4) [0x7fbc9cfeeff4]
[panther2:46075] [ 5] /home/temok/opt/openmpi-1.6.5/build-gcc/./lib/openmpi/mca_pml_ob1.so(mca_pml_ob1_isend+0x4b0) [0x7fbc9cfe7350]
[panther2:46075] [ 6] /home/temok/opt/openmpi-1.6.5/build-gcc/./lib/openmpi/mca_coll_tuned.so(ompi_coll_tuned_bcast_intra_generic+0x323) [0x7fbc9b91d2a3]
[panther2:46075] [ 7] /home/temok/opt/openmpi-1.6.5/build-gcc/./lib/openmpi/mca_coll_tuned.so(ompi_coll_tuned_bcast_intra_binomial+0xd8) [0x7fbc9b91d638]
[panther2:46075] [ 8] /home/temok/opt/openmpi-1.6.5/build-gcc/./lib/openmpi/mca_coll_tuned.so(ompi_coll_tuned_bcast_intra_dec_fixed+0xcc) [0x7fbc9b91505c]
[panther2:46075] [ 9] /home/temok/opt/openmpi-1.6.5/build-gcc/./lib/openmpi/mca_coll_sync.so(mca_coll_sync_bcast+0x78) [0x7fbc9bb2b6b8]
[panther2:46075] [10] /home/temok/opt/openmpi-1.6.5/build-gcc/lib/libmpi.so.1(MPI_Bcast+0x130) [0x7fbca073c3b0]
[panther2:46075] [11] /home/temok/opt/openmpi-1.6.5/build-gcc/lib/libmpi_f77.so.1(pmpi_bcast+0x7e) [0x7fbca0a935be]
[panther2:46075] [12] ../../../QEspresso/espresso-5.0.2/bin/pw2wannier90.x(bcast_integer_+0x192) [0x60d742]
[panther2:46075] [13] ../../../QEspresso/espresso-5.0.2/bin/pw2wannier90.x(__mp_MOD_mp_bcast_iv+0x97) [0x5feff7]
[panther2:46075] [14] ../../../QEspresso/espresso-5.0.2/bin/pw2wannier90.x(read_nnkp_+0x1bbf) [0x44220f]
[panther2:46075] [15] ../../../QEspresso/espresso-5.0.2/bin/pw2wannier90.x(MAIN__+0x9c9) [0x447b49]
[panther2:46075] [16] ../../../QEspresso/espresso-5.0.2/bin/pw2wannier90.x(main+0x2a) [0x72267a]
[panther2:46075] [17] /lib64/libc.so.6(__libc_start_main+0xfd) [0x31a021ed1d]
[panther2:46075] [18] ../../../QEspresso/espresso-5.0.2/bin/pw2wannier90.x() [0x42b819]
[panther2:46075] *** End of error message ***
--------------------------------------------------------------------------
mpirun noticed that process rank 0 with PID 46075 on node XXXXXXXX exited on signal 11 (Segmentation fault).
--------------------------------------------------------------------------

_______________________________________________
Wannier mailing list
Wannier at quantum-espresso.org<mailto:Wannier at quantum-espresso.org>
http://www.democritos.it/mailman/listinfo/wannier

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.democritos.it/pipermail/wannier/attachments/20140327/714ce593/attachment.htm 


More information about the Wannier mailing list